**

Скачать программу для создания флеш сайтов и анимации Adobe Flash Builder

Скачать программу для создания флеш сайтов и анимации Adobe Flash Builder

Программа для создания сайтов и анимации — Adobe Flash Builder — инструмент, позволяющий разрабатывать «насыщенные интернет-приложения», использующие технологию Flash, созданную в Macromedia, а затем развитую компанией Adobe Systems. Эта технология позволяет создавать компьютерные игры, презентации, сайты с богатой анимацией и даже приложения мобильного банка.

Созданные приложения могут запускаться как браузером, поддерживающим технологию Flash, так и непосредственно на персональном компьютере. Есть версия Flash для мобильных устройств.

Исходный код приложений для Flash создается на языке программирования ActionScript, их интерфейс описывается на декларативном языке MXML – расширении языка XML. В результате создается файл с расширением .swf, который может быть запущен браузером либо непосредственно с компьютера.

Скачать программу для создания флеш сайтов и анимации Adobe Flash Builder


До версии 4.6 включительно Flash Builder содержал визуальный редактор для разработки внешнего вида приложения, но в версии 4.7 от визуального редактора отказались.

Программа выпускается в вариантах Standard и Premium. Вариант Premium дополнительно включает средства для профилирования, автоматического тестирования, мониторинга данных, передаваемых по сети. Существуют также варианты Standard и Premium, позволяющие разрабатывать серверную часть приложения на PHP.

Программа может работать как под управлением операционных система Windows (не ниже Windows XP с пакетом обновлений SP3), так и в операционных системах MacOS X (не ниже 10.6).

Системные требования для установки программы:

  • процессор: частота не менее 2 ГГц

  • память: от 2 Гбайт

  • место на диске: не менее 5 Гбайт для Windows или 4 Гбайт для OS X


В основе Adobe Flash Player лежит среда разработки Eclipse, поэтому для работы с программой необходимы предварительно установленная виртуальная Java-машина (JRE 1.6 или 1.7), а для установки дополнений потребуется также Eclipse версии 3.7 или 4.2.

Навигация

Ваше мнение

Какой браузер вы используете?

Firefox
Opera
Chrome
Internet explorer
Safari
Результаты